Wednesday, December 28, 2011

cisco configuration 851 dhcp

Building configuration...

Current configuration : 3755 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CISCO851
!
boot-start-marker
boot-end-marker
!
enable secret *************
!
no aaa new-model
!
resource policy
!
clock timezone il -2
clock save interval 8
ip subnet-zero
no ip dhcp use vrf connected
!
ip dhcp pool lan
   network 192.168.1.0 255.255.255.0
   dns-server 80.179.55.100 80.179.52.100
   default-router 192.168.1.1
!
ip dhcp pool 2
   host 192.168.1.100 255.255.255.0
   client-identifier 000000000000000
!
ip dhcp pool 1
   host 192.168.1.101 255.255.255.0
   client-identifier 00000000000
ip cef
ip vrf mishmish
!
no ip domain lookup
ip domain name cisco
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
password encryption aes
!
crypto pki trustpoint TP-self-signed-3944136632
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3944136632
 revocation-check none
 rsakeypair TP-self-signed-3944136632
!
!
interface FastEthernet0
!
interface FastEthernet1
 duplex half
 speed 10
!
interface FastEthernet2
 duplex full
 speed 100
!
interface FastEthernet3
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 dhcp
!
ip http server
ip http secure-server
ip nat inside source list 18 interface FastEthernet4 overload
ip nat inside source static tcp 192.168.1.3 8080 interface FastEthernet4 8080
ip nat inside source static tcp 192.168.1.2 81 interface FastEthernet4 81
ip nat inside source static tcp 192.168.1.150 1983 interface FastEthernet4 1983
!
access-list 18 permit 192.168.1.0 0.0.0.255
!
control-plane
!
banner motd ^C
no
^C
alias exec s sh ip int br
alias exec r sh run
alias exec t configure terminal
alias exec a sh arp
alias exec c sh clock
!
line con 0
 logging synchronous
 no modem enable
line aux 0
line vty 0 4
 password 7 **********
 logging synchronous
 login
 transport input all
!
scheduler max-task-time 5000
end

No comments:

Post a Comment